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Plan Explorer Installation & Overview
Last Modified on 15 July 2021

Introduction
Plan Explorer is a FREE lightweight .NET-based tool that builds upon and supplements the capabilities of

SSMS for execution plan analysis. The following high value features are available:

Helpful color, costing, and layout options for plan diagrams

Many runtime metrics unavailable in SSMS plans

Index scoring and histogram analysis

Live query profile with resource charts

Wait statistics with links to the SQLskills wait types library

Full query call stack for dynamic SQL and iterative queries

Session history, versioning, and comments

Unique analysis and visualization of deadlocks

In addition to this guide, there are several blog posts and videos available that explain and demonstrate how

and why you should use Plan Explorer.

Installation

Download: Plan Explorer is available for free here.

SQL Sentry Plan Explorer is a single installation file. Double-click the PlanExplorerInstaller.exe file to start

the installation.

Command Line Install

If you want to install Plan Explorer through the command line, enter the prompt PlanExplorerInstaller.exe /?

to display the following switches:

https://blogs.sentryone.com/category/plan-explorer/
https://www.youtube.com/playlist?list=PL-VeedM-AiI-o35qRT54LhIJROztDvlpy
https://www.sentryone.com/plan-explorer#download
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Switches Description

/install | /repair |
/uninstall |
/layout

Installs, repairs, uninstalls, or creates a complete local copy of the Plan Explorer
bundle in the directory.

Note:  Install is the default option.

/passive | /quiet
Passive displays minimal with no UI, while quiet displays no UI and no prompts.

Note:  The UI and all prompts display by default.

/norestart
Suppresses any attempts to restart.

Note:  The UI prompts you before restarting by default.

/log log.txt
Logs to a specific file.

Note:  A log file is created in %TEMP% by default. 

Note:  Windows may warn you about User Account Control (UAC) permissions being required for SQL

Sentry Plan Explorer Setup. This popup will happen in passive and quiet modes. Open Command

Prompt with the Run as administrator  option to avoid this popup when running Plan Explorer

commands during your session.

Syntax example:

c:\Users\mconnors\Downloads>PlanExplorerInstaller.exe /repair /quiet

Overview

Updates
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Plan Explorer checks our servers to ensure you're using the most recent version, and it offers to update your

software if there's a newer version available. Do this manually by using Help > Check for Updates.

It also checks each time you launch the application. Disable this automatic check through User Preferences

(Tools > User Preferences).

File Types

Plan Explorer opens several different file types, including raw plan XML files, SQL plan files, and

.QueryAnalysis files, as well as deadlock files and Plan Explorer Session files.

Plan Explorer Sessions

Plan Explorer uses Plan Explorer Session files (.pesession) to manage changes and version history as you

refine queries. Plan Explorer Session files are completely portable, and contain the entire Plan Explorer

session (the individual .queryanalysis files), including versioning. For more information, see the PE Sessions

topic.

Deadlocks

Plan Explorer supports opening deadlock files (.xdl). For more information, see the Deadlock Files topic.

Query Analysis File (.QueryAnalysis)

All information shown in Plan Explorer is saved to the .QueryAnalysis file format by selecting Save. This

proprietary, portable format contains the single plan XML along with additional information, including actual

statements and actual metrics captured by extended events, server-side trace, and other sources.

DBAs can easily save all estimated and actual data for a query to file for later analysis or share it with other

team members. For example, a DBA using the full version of SQL Sentry can send a .QueryAnalysis file to a

developer for tuning, and all the developer needs is the Plan Explorer utility instead of the entire SQL Sentry

Select User Preferences on toolbar

User Preferences window

http://app.knowledgeowl.com/help/plan-explorer-sessions
http://app.knowledgeowl.com/help/deadlock-files
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client application.

SQL Plans and Execution Plan XML

Plan Explorer includes support for opening Execution Plan files (.sqlplan) and Execution Plan XML files

(.xml).

Viewing Query Plans
There are multiple ways to view a query plan in Plan Explorer:

Using the management studio Add-In (bundled with the installer), save an execution plan from SSMS to

a .sqlplan file, open the file using the Open toolbar button or  File > Open. Raw plan XML files and

.QueryAnalysis files are also supported. Right-click a plan in SSMS, and then select View with SQL

Sentry Plan Explorer. This opens the plan(s) in Plan Explorer, providing the correct server/database

context for further operations.

In SSMS, right-click a graphical plan, select Show Execution Plan XML, and then copy and paste the plan

XML into Plan Explorer. It doesn’t matter which pane is active; the clipboard handler is global and auto-

detects the plan XML. This makes it quick and easy to move plans from SSMS into Plan Explorer if

you’re not using the SSMS Add-in.

https://www.sentryone.com/plan-explorer
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Right-click an existing .sqlplan file, and then select Open with Plan Explorer, or drag and drop the plan

file onto the application.

Retrieve the estimated or actual plan from T-SQL in the Command Text pane using the Get Estimated

Plan (CTRL + L) or Get Actual Plan (CTRL + E/F5)  button on the toolbar. The connection dialog box

opens to connect to a valid SQL Server instance, unless Plan Explorer launched using the Add-in, in

which case the connection information is pre-populated.
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Note:  Plan Explorer currently supports Windows and SQL Server authentication modes. AD

authentication methods are not available.

Retrieving the Estimated Plan

Copy and paste or type raw T-SQL into the  Command Text tab, and then select Get Estimated Plan , or use

the CTRL + L keyboard shortcut to connect to a server and get the estimated plan.

Note:  Get Estimated Plan  requests the estimated plan for that query from SQL Server. A valid

version of the plan will be retrieved from cache or it will be generated. It does not use the Query Store.

Plan Diagram Context Menus

Once you have a plan loaded, right-click anywhere in the diagram area to access context menus that control

how the graphical plan is displayed. Color-scaling and per node costs are enabled by default.
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Actual Plans
If an actual plan loads, actual metrics are shown by default. Toggle the plan diagram back and forth between

estimated and actual metrics using the Show Estimated Plan toolbar button. This button is only enabled

when an actual plan is loaded.

Generating an Actual Plan

Warning:  Get Actual Plan  executes the T-SQL commands. If they include any DML (i.e. updates,

inserts, or deletes), then it will update the database.

To generate an actual plan, use the Get Actual Plan button on the toolbar, or use the CTRL-E / F5 keyboard

shortcut. When generating an actual plan, the query is executed against the server. All the statements in the

text data are executed. This allows you to collect actual runtime metrics, such as duration, CPU and reads,

which you cannot get from an estimated plan. By design, the actual query results aren't returned to the Plan

Explorer interface.

When you generate an actual plan, an execution warning message appears. Disable this warning message

through User Preferences (Tools > User Preferences > Warn on actual execution).

Get Actual Plan 

User Preferences window

http://app.knowledgeowl.com/help/menus
http://app.knowledgeowl.com/help/toolbars
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Full Query Call Stack

When an actual plan is retrieved in Plan Explorer, the full query call stack is also assembled. This ability has

been part of Performance Analysis in SQL Sentry for some time, and was also made available as part of the

Plan Explorer feature set.

Plan Explorer offers the complete call stack, including nested procedure calls and statements called with

dynamic SQL. The complete query call stack is invaluable as it lets you see exactly how all the captured

statements are related and where they fit in the query plan. Most importantly, it shows you which statements

did the bulk of the work, and which are candidates for optimization.

Wait Stats

When an actual plan is retrieved with related wait stats, the Wait Stats tab is displayed next to the Results

tab. The wait type is shown along with any associated wait time or signal time.

The Wait Stats tab helps you in identifying potential resource bottlenecks, including those related to

memory pressure, CPU pressure, disk I/O, and networking. For more information about wait types, see the

sys.dm_os_wait_stats (Transact-SQL) article.

Note:  For a complete list of the wait types and their locations in SQL Server 2005 through SQL Server

2017, see the SQLskills Wait Types Library.

https://www.sentryone.com/platform/sql-server-performance-monitoring
http://technet.microsoft.com/en-us/library/ms179984.aspx
https://www.sqlskills.com/help/waits/
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Note:  Wait Stats Analysis is only supported for queries executed against servers running SQL Server

2008 or newer.

Exception Reporting
If you're working in Plan Explorer and see a small form pop-up, it means we’ve captured an unhandled

exception. Enter your name and email address along with brief steps to reproduce the exception into the

textbox, then submit it. If the exception seems to pertain to a particular plan, save it to a .QueryAnalysis file

and contact us at support.sentryone.com

https://support.sentryone.com/s/
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Plan Explorer Azure Data Studio Extension
Last Modified on 29 November 2021

Overview

The SentryOne Plan Explorer Extension for Azure Data Studio (ADS) is a FREE extension that provides you

with enhanced query plan diagrams for batches run in ADS. Optimized layout algorithms and intuitive color-

coding help you quickly identify operators in your execution plans that are slowing database performance.

With the SentryOne Plan Explorer ADS extension, you can:

View operator costs (per node) by CPU or I/O

Control the graphical plan display with plan diagram context menus

Analyze runtime metrics such as duration and CPU

Toggle between actual and estimated plans

Save ShowPlan XML to send to other users, or open in Plan Explorer

Additional Information: See Aaron Bertrand's blog post, SentryOne Plan Explorer Extension for Azure

Data Studio, for release notes and details about the extension, including some known issues and how to

provide feedback.

System Requirements

The following is required to install the SentryOne Plan Explorer ADS Extension:

Azure Data Studio 1.9.0 or higher

.NET Core Runtime 2.1 or higher

Recommended System Configuration

2 or more cores 

8 GB or more of memory

Compatible Operating Systems

Windows (8.1 / Server 2012 R2 or higher)

https://sqlperformance.com/2019/07/sentryone/plan-explorer-extension-azure-data-studio
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macOS (10.13 or higher)

RedHat (7.6 or higher)

SuSE (12.0 or higher)

Ubuntu (18.04 or higher)

Installing the Plan Explorer Extension

 Important:  You must create a free SentryOne Cloud account and agree to the End User License

Agreement to access the SentryOne Plan Explorer ADS Extension.

Once you've created your account, complete the following steps to Install the Plan Explorer ADS Extension: 

1. Download the Plan Explorer Azure Data Studio Extension from extensions.sentryone.com.

2. Open Azure Data Studio, and then select File > Install Extension from VSIX Package.

3. Select the Plan Explorer Azure Data Studio Extension VSIX file, and then select Install.

http://extensions.sentryone.com
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4. Select Yes on the warning prompt to install the Plan Explorer Extension.

5. The installation completes.
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Success: The Plan Explorer Azure Data Studio Extension has installed successfully!

 Important:  After you have downloaded, and successfully installed the Plan Explorer ADS Extension,

the Extension will be enabled in Azure Data Studio by default.

Enabling the Plan Explorer Extension

 Important:  After you have downloaded, and successfully installed the Plan Explorer ADS Extension,

the Extension will be enabled in Azure Data Studio by default.

You can also enable or disable the Plan Explorer ADS Extension for any desired plan by doing one of the

following:

Selecting SentryOne Plan Explorer in the status bar
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Open the Command Palette by selecting CTRL+Shift+P and then selecting Toggle SentryOne Plan

Explorer

Entering the Keyboard Command Shortcut CTRL+Shift+F5

Note:  After enabling the SentryOne Plan Explorer Extension, the Plan Explorer On notification

displays in Azure Data Studio.

Select SentryOne Plan Explorer SentryOne Plan Explorer On

CTRL+Shift+P and select Toggle SentryOne Plan Explorer



18

Using the SentryOne Plan Explorer Extension
Use the SentryOne Plan Explorer extension to see a detailed query plan for your desired query. Complete the

following steps to view an Actual Plan or an Estimated plan: 

Viewing an Actual Plan

1. Enable the SentryOne Plan Explorer Extension for ADS.  

2. Enter a new, or load an existing query, and then select Run to collect an Actual Plan and open a Plan

Explorer Statement tab.  

3. Select View Plan to open the Actual Plan for the selected query statement.

Viewing an Estimated Plan

1. Enable the SentryOne Plan Explorer Extension for ADS.  

2. Enter a new, or load an existing query, and then select Explain to collect an Estimated Plan and open a

Plan Explorer Statement tab.  

Run Query Plan Explorer Statements tab

Select View Plan Plan Explorer Query Diagram for Actual Plan
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3. Select View Plan to open the Estimated Plan for the selected query statement.

Plan Explorer Statement Tab

The Plan Explorer Statements tab opens automatically when a query is run and the Plan Explorer extension is

enabled. The Statements tab separates the query into statements, and provides Duration and CPU

information about those statements.

Select Explain
Plan Explorer Statements tab

Select View Plan
Plan Explorer Query Diagram for Estimated Plan
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Feature Description

Statement An individual statement within the query.

Duration The amount of time in milliseconds it took for the query statement to complete.

CPU The amount of CPU used to process the query statement.

View Plan Select View Plan to open a detailed query plan of the selected statement.

View XML Select View XML to open the ShowPlan XML for the selected statement.

Plan Explorer Query Plan Diagram

The Plan Diagram uses an optimized layout algorithm that renders plans in a much more condensed view, so

more of the plan fits on the screen without having to zoom out. You can zoom in and out by selecting CTRL +

Mouse Wheel. Optimized plan node labels prevent truncation of object names in most cases. 

The estimated cost of the operation is displayed above each node for maximum readability. These cost labels

use color scaling by CPU, IO, or CPU+IO so highest cost operations are instantly obvious, even on larger plans.

CPU + IO is used by default; change this through the  Costs By context menu. All costs in the  Plan Diagram

are shown to the first decimal place.
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Through the context menu of the Plan Diagram, choose to show cumulative costs in lieu of per node costs;

when combined with color scaling, this feature makes it easy to see which subtrees are contributing most to

the plan cost. 

Hover over a Plan Diagram operator to display a truncated tooltip that provides details about the operator. 

Select the operator to display the operator's detail window.

Note:  Return to the Plan Explorer Statements tab by selecting the  button.
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Note:  The SentryOne Plan Explorer ADS Extension is compatible with any theme in ADS.

Plan Diagram Context Menu

The following context menu options are available:

Option Description

Actual Shows metrics captured during Actual Plan retrieval.

Estimated Shows metrics associated with the Estimated Plan.

Show per
Node costs

The default view, costs are per node, representing each individual nodes contribution
to the total cost.

Show
Cumulative
costs

Costs are cumulative, representing each individual nodes contribution plus the
contribution of any of its children.

Costs By I/O—Show costs by I/O CPU—Show costs by CPU CPU + I/O—Show costs by CPU +I/O

Line Widths
By

Rows — Show line widths by the number of rows created. Data Size — Show line
widths by the volume of data used.
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Show Color
Scale

When Show Per Node costs is selected, node costs are highlighted with an appropriate
color scale, ranging from a light yellow to red. When Show Cumulative costs is
selected, node costs are highlighted with an appropriate color scale, ranging from light
blue to dark blue.

Missing
Index
Details

Displays any missing indexes in an untitled document window.

Zoom Various options for zooming in and out. Alternatively, use CTRL + Mouse Wheel.

Option Description

Showplan XML

Select View XML to open the ShowPlan XML tab for the selected statement.  

You can copy and save the Showplan XML, and then open it in Plan Explorer. 

Missing Index Details

The Missing Index details option is selectable from the Plan Explorer context menu if you query has any

missing indexes. Open the Missing Index details for your query in an untitled document window by selecting

Select View XML Plan Explorer XML

Copy Show Plan XML

Open XML in Plan Explorer
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Missing Index details.

Api Port Settings

The default API port for the SentryOne Plan Explorer ADS Extension has been updated to 5042 to avoid

potential conflicts. To change the API port, complete the following steps:

1. Select and then select Settings.

2. Select Extensions, and then select SentryOne Plan Explorer.

Select Missing Index Details Missing Index Details window
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3. Enter your new Port Value. 

Note:  Any changes you make to the Plan Explorer Api Port are saved automatically.
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Integrated Plan Explorer Overview
Last Modified on 15 July 2021

Note:  The functionality between the standalone and integrated Plan Explorer is nearly the same. See

the following information for more details about Plan Explorer.

Note:  The default value for the Query Collection Maximum Text Length setting is truncated at

10,000 characters. It may be set to a value between 10,000 and 50,000 characters. For more information,

see the Adjusting Captured Text Data  topic.

Plan Explorer is designed to make query plan analysis fast and intuitive. There are several ways to start a

new Plan Explorer Session  within SQL Sentry. On the Top SQL tab, the View button in the Plan column

opens a Plan Explorer Session  for the associated completed or running query. Start a new Plan Explorer

Session with the New Plan Explorer Session toolbar button or through the File menu.

Plan Explorer Sessions  (.pesession) are designed to help you manage a historical record as you fine tune

queries. By default, a historical entry is generated as part of the Plan Explorer Session  during Estimated and

Actual Plan retrieval. For more information, see the Plan Explorer Sessions topic. 

http://app.knowledgeowl.com/help/bi-sentry-performance-analysis-top-sql#querycollectionmaxtextlength
http://app.knowledgeowl.com/help/plan-explorer-sessions
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Note:  Several of our team members have written about the available features and benefits of using

SQL Sentry Plan Explorer. Find all of our Plan Explorer related posts on our team blog.

General Layout Information
The screen and window layout of Plan Explorer is persisted by default, and can be saved to and loaded from

a disk. Default horizontal and vertical layout styles are included; the horizontal layout is better suited for

shorter queries with wide plans, while the vertical layout is better suited for longer queries. Change the layout

by selecting the desired layout button on the toolbar or through the context menu of any section's header.

Entire plans can be saved to and loaded from a file, complete with all statement and plan information. Save a

plan by selecting Save on the toolbar or through the File menu. A Save As command is also available from the

File menu, allowing you to keep different versions of similar plans.

Customizable Tab Layout

The Plan Explorer tab layout is completely customizable. Each tab fully undocks from its parent window,

allowing you to simultaneously view the Plan Diagram alongside any other chosen query detail tabs. To

undock a tab from its parent window, select and drag the tab's title bar. Choose to either re-dock the tab with

an existing tab, or float the tab in a standalone window. Use the push-pin to unpin the tab from the

immediate docked view, and it becomes auto-hidden when not in use.

Statements Section
The Statements Tree tab shows a tree list representation of the entire query call stack, including all

statements, conditional logic structures, looping structures, nested procedure calls, and dynamic SQL calls.

Estimated costs (Total, CPU, and IO) and estimated rows are displayed for each statement, and actual costs

and rows are shown side-by-side for any statements captured from the Top SQL collection or for Actual

Plans generated within the Plan Explorer Session. Any significant differences between estimated and actual

rows for captured statements are highlighted, making it easy to spot cases where statistics may be stale.
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Each of the three sections are automatically synchronized when you select a statement. This includes all the

tabs in the Plan Details section. Use the Statements Tree to quickly find the highest cost statements.

Selecting any statement shows the graphical diagram, top operations list, columns list, and tree list view for

the statement’s execution plan.

The Command Text tab allows editing of the SQL for Estimated and Actual Plan retrieval.

Query Information Section

Query Information Tabs

Query Information tab Image



29

The Text Data tab displays the color-coded T-SQL
batch or procedure definition of the plan.

Save the text with the Save SQL context menu
command, or copy the text data to the Command
Text tab with the Copy To Command Text
context menu command.

The Plan XML tab displays the execution plan in
XML format.

Save the plan in .sqlplan format, with the Save
Execution Plan context menu command.

The Plan/Query Info tab provides detailed
information about the selected query and query
plan.

Note:  Information displayed in the Plan/Query
Info tab is only available for queries captured by
the SQL Sentry Monitoring Service.

Query Information tab Image

Plan Details Section
When you select a statement in the Statements Section, all the tabs in the Plan Details section are

synchronized with the selected statement. To inspect or make modifications to an index, open the index

properties window by right-clicking any index operation node in the Plan Diagram tab, or any grid row within

the other Plan Details tabs; likewise, create new indexes from a separate context item. When you select an

operation in any of the Plan Details tabs it's automatically synchronized. Select Copy, available through the

right-click context menu, to copy any of the grid view data in the Plan Details section.

Plan Diagram Context Menu
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The Plan Diagram tab has an optimized layout algorithm that renders plans in a much more condensed view

than SSMS, so more of the plan fits on the screen without having to zoom out. If needed, zoom in and out by

selecting CTRL + Mouse Wheel. Optimized plan node labels prevent truncation of object names in most

cases. To disable truncation completely so full object names are always visible, select Show Full Object

Names from the right-click context menu.

The estimated cost of the operation is displayed above each node for maximum readability. These cost labels

use color scaling by CPU, IO, or CPU+IO so highest cost operations are instantly obvious, even on larger plans.

CPU + IO is used by default; change this through the  Costs By context menu. All costs in the  Plan Diagram

are shown to the first decimal place.

Through the context menu of the Plan Diagram, choose to show cumulative costs in lieu of per node costs;

when combined with color scaling, this feature makes it easy to see which subtrees are contributing most to

the plan cost. 

Scale the connector line width by either row or data size with the Line Widths By context menu command.

The metric you choose to scale by is displayed above all connector lines within the Plan Diagram.

Plan Detail Tabs

Plan Details Tabs Grid Legend

Icon Description

The check mark indicates a value of Yes.

The empty box indicates a value of No.
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The filled box indicates a value of Not Applicable. 

Icon Description

The Plan Tree tab is a tree representation of the plan that shows all operations and associated metrics. Use

the arrows to expand and collapse sections of the Plan Tree. Right-click any column header, and use the

Column Chooser command to access additional plan metrics. Any significant differences between estimates

and actuals are highlighted, as are possible problematic operations like scans and bookmark lookups.

The Top Operations tab contains a sortable list view of all plan operations that's sorted by total cost

descending by default so you can immediately see which operations are the highest cost.

The Query Columns tab shows exactly how data is accessed for each column used by the query, including the

associated operation and estimated rows. This view makes it easy to identify bookmark lookups or index

scans occurring because indexes are non-covering.
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The Parameter tab shows all statement parameters with runtime and compiled values.

When an Actual Plan is captured or generated, the Table I/O tab is shown. This tab breaks down all the reads

from a query by object, making it easy to see where most of your I/O is coming from.

The Wait Stats tab was introduced as part of the feature set of SQL Sentry 7.2. When an Actual Plan is

retrieved with related wait stats, the Wait Stats tab displays next to the Results tab. The wait type is shown

along with any associated wait time or signal time. The Wait Stats tab helps you in identifying potential

resource bottlenecks, including those related to memory pressure, CPU pressure, disk I/O, and networking.
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Note:  Wait Stats are available for queries executed against servers running SQL Server 2008 or

newer.

Plan History
SQL Sentry tracks all plan versions for a query over time, so you can easily determine when a plan has changed

and caused query performance problems. The plans are the Estimated Plans collected at the time of query

execution. For more information, see the Query Plans topic. 

http://app.knowledgeowl.com/help/db-sentry-query-plans
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Plan Explorer Navigation
Last Modified on 15 July 2021

The following are the primary features and information about the different tabs found within Plan Explorer.

Since the graphical plan diagram in SSMS was used as a starting point for the design of Plan Explorer, some

features are compared with the current capabilities of SSMS to illustrate the reasoning behind the feature.

Plan Explorer Menus

File Menu

Command Description

New Creates a new Plan Explorer Session  in a new tab. 

Open
Opens an existing Execution Plan file (.sqlplan | .xml | .queryanalysis | .pesession),
deadlock file, or SQL file.

Save Saves the current file.

Save
As

Saves the current file with a new name/new location.

Save
All

Saves all files opened in any tabbed sessions.

Recent
Files >

Displays a list of recently opened files.

Exit Exits the program.

View Menu

http://app.knowledgeowl.com/help/plan-explorer-sessions
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Command Description

Plan History Opens the Plan History pane.

Comments Opens the Comments pane.

Start Page Opens the Start Page pane. 

Plan Layout
Control

Opens the Layout Editor. Use the Layout Editor to customize the position of
the various panes.

Tools Menu

Command Description

User Preferences Allows you to edit the user preferences. 

Edit Connection Allows you to edit the server connection. 

Anonymize Plan Allows you to anonymize a .sqlplan. 

Window Menu
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Command Description

Float

Allows the selected panel to detach from the main window rather than being
docked.

Note:  This can also be done by dragging the panel by its titlebar.

Close All
Documents

Closes all open query plans. 

Reset Window
Layout

Resets the windows to the default state.

New Horizontal
Tab Group

Creates a new Horizontal tab group with the selected tab.

New Vertical Tab
Group

Creates a new Vertical tab group with the selected tab.

Move to Next Tab
Group

Moves the selected tab group to the next group.

Move to Previous
Tab Group

Moves the selected tab group to the previous group.

1 Plan Opens the desired query plan. 

Windows...
Uses the Windows command to manage all your open windows. Uses the
Activate command to set focus to the selected window.

Help Menu

Command Description

Plan Explorer Help Opens to Plan Explorer in the SQL Sentry User Guide. 

Check for Updates Checks for the newest version of  Plan Explorer.

About
Views information about Plan Explorer, including build number and contact
information.

http://app.knowledgeowl.com/help/plan-explorer-installation
http://app.knowledgeowl.com/help/recommendations
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End User License
Agreement

Opens the www.solarwinds.com/legal/eula article about licensing information. 

Command Description

Toolbar

Button Description

New—Creates a new Plan Explorer Session in a tab.

 Open—Opens an existing Session file, Execution Plan, Deadlock, or SQL file,

 Save—Saves the current file.

Save All—Saves all the currently open files.

 Copy—Copies the selected text to the clipboard. 

 Paste—Pastes the selected text from the clipboard.

Comment selected lines — Makes the selected line(s) a comment.

Uncomment selected lines — Removes the comment tab from the selected line(s).

Button Description

Edits the current connection information.

Generates an Estimated Plan. (Shortcut Key: CTRL-L)

Generates an Actual Plan. (Shortcut Key: F5 or CTRL-E)

Select the With Live Query Profile  option from the drop-down list. A usage chart

appears that plots CPU, I/O and waits. 

Note:  Disable the Query Execution warning message with User

Preferences (Tools > User Preferences > Warn on actual execution).

https://www.solarwinds.com/legal/eula
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Stops the execution of a query.

Toggles the Plan Diagram tab between the Estimated and Actual Plan.

Horizontal Layout—Switches the current tab to a horizontal layout.

Vertical Layout—Switches the current tab to a vertical layout.

Button Description

Command Text

The Command Text section shows an editable version of the query text for the statement or batch being

analyzed. Make changes to the query, then see how this impacts the execution plan by selecting Get

Estimated Plan or Get Actual Plan on the toolbar.

When retrieving a plan, you're asked for the server, database, and credentials to connect (unless you launched

Plan Explorer from within SSMS using our Management Studio Add-In).

To generate the Actual Plan, the query is run against the target server. By design, the actual query results

aren't returned to the Plan Explorer interface. By default, there's a message box explaining this behavior

when an Actual Plan is captured.

Note:  Disable the Query Execution warning message with User Preferences (Tools > User

Preferences > Warn on actual execution).

If query execution fails, a message displays in the Status bar, located at the bottom of the Plan Explorer

window.
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Plan Explorer Sessions
Last Modified on 15 July 2021

Plan Explorer introduces the concept of a Plan Explorer Session  and its associated Plan Explorer

Session file (.pesession). Plan Explorer Session files are completely portable, and contain a record of the

entire session, including versioning.

Plan Explorer Sessions are designed to help you manage a historical record as you refine queries. By default,

a historical entry generates as part of the Plan Explorer Session during Estimated and Actual Plan retrieval.

Note:  Change how Plan Explorer generates new historical entries through User Preferences (Tools

> User Preferences > Performance Analysis tab). The Only save history when command text or

Instance settings change  option controls this behavior.

Version History
Each historical entry retains all captured plan details and metrics within the various Plan Explorer tabs. Each

version is associated with a unique version number. Plan Explorer includes a Plan History pane (View > Plan

History) that allows you to navigate through the different versions within the active Plan Explorer Session.

To delete a version, select Delete in the History pane context menu.

Note:  The Status bar, located at the bottom of the Plan Explorer window, updates as actions are

taken, including each time a new historical version is loaded. 

Adding Comments
Plan Explorer allows you to add comments to each historical version ( View > Comments). This allows you to

keep track of the reasoning behind any changes you make, like changes to the Command Text or any indexing

optimization. You can also add comments in the Plan History pane by selecting the Comments drop-down list.

 

View Plan History
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Multiple Sessions and Tabs
As each session is managed within its own tab, multiple Plan Explorer Sessions can be open at the same

time. SQL Sentry Plan Explorer was designed with a multiple document interface, allowing you several options

when managing tabbed sessions, including the ability to arrange tabs horizontally and vertically, and the

ability to tear off tabs. Tab Windowing options are found in the Window menu.

Sharing Session Files
Plan Explorer Session files are easily shared with others, even if they don't have access to the full SQL Sentry

client.

SQL Sentry Plan Explorer is a stand-alone query analysis tool. Plan Explorer uses session files to manage

history, just like the integrated Plan Explorer, and contains complete support for opening  Plan Explorer

Session files generated in the SQL Sentry client.

Plan Explorer also opens session files in a limited fashion. When you open a Plan Explorer Session file

(.pesession) for the first time in Plan Explorer, it'll by default open the first history entry. If you've opened

the session file previously, it'll open the last history item you were viewing. You can easily switch between

history items using View > Plan History. 

This is possible because each historical entry in a Plan Explorer Session is actually a .queryanalysis file. Plan

Explorer Session files are archive files, containing the individual .queryanalysis files and metadata about the

session.

Note:  Save any single historical entry of a Plan Explorer Session as a stand-alone .queryanalysis

file. With the entry you wish to save as active, select Save As (File > Save as), and then choose the

desired file type.

Starting a New Session
Start a new Plan Explorer Session by completing any of the following:

Comments pane

Plan History pane comments

http://www.sqlsentry.com/plan-explorer/sql-server-query-view.asp
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Option Image

Select File > New

Select Toolbar > New Plan Explorer Session icon,
or drag-and-drop a plan file onto the application.

Saving a Session
Save a Plan Explorer Session  by completing either of the following:

Option Image

Select File > Save / Save As

Select Toolbar > Save icon

Anonymize Plans

SQL Sentry Plan Explorer can obfuscate the sensitive data in your plans. Plan Anonymization changes all

Database, Table, and Column names in your plans to generic representations. 

To use this feature, select Tools > Anonymize Plan.

Your original plan is preserved in the current tab, and the anonymized plan is opened in a new tab.
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Note:  For more information, see the Anonymize your plan details natively in Plan Explorer  blog post.

http://www.sqlperformance.com/2013/03/sql-performance/anonymize-your-plans
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Plan Explorer Results
Last Modified on 25 June 2021

Video

Statement Section
The top section of the Results tab contains the Statement section or Statements tree. The Statement

section represents one of the biggest differences between Plan Explorer and SSMS. Its function is critical

when navigating multi-statement plans. It shows a logical breakdown of the entire plan tree, including all

control structures, nested procedure calls, and estimated and/or actual metrics for each statement, including

operation counts.

Common Operations

Select any statement in the grid to show the associated plan for that statement.

Select any control structure (If or While), or Exec higher up the tree to see a filtered view of the plan

starting from that point.

Sort the statements list and the highest cost trees, and statements immediately bubble up to the top.

Context Menu Commands
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Command Description

Show Captured
Statements Only

Note:  Applicable to only .queryanalysis files that originate in the SQL
Sentry Performance Analysis integrated version of  Plan Explorer.

In the integrated version of Plan Explorer only statements that exceed the

trace filters display by default. If a statement is part of the query call stack, but

doesn't exceed the filters it's hidden. This helps you in quickly identifying the

costliest parts of the query. Unchecking this option shows the entire query call

stack.

Show Hidden
Captured
Statements

Note:  Applicable to only .queryanalysis files that originated in the SQL
Sentry Performance Analysis integrated version of Plan Explorer. In the
integrated version of Plan Explorer, you're able to hide statements in the
Statements tree. If checked, those statements are no longer hidden.

Expand Subtree Expands all the child nodes of the selected statement.

Expand All Expands the entire Statement tree.

Collapse All Collapses the entire Statement tree.

Edit Connection Allows you to edit the SQL Server connection. 

Copy > Copies the cell, row, or all query information to the clipboard. 

Copy Statement to
Command Text

Copies the selected statement to the Command Text tab, overwriting any text
currently in the tab.

Copy All
Statements to
Command Text

Copies all statements belonging to the query call stack over to the Command
Text tab.

Note:  When using a column filter that uses a percent value, use a decimal value for the filter. For

example, if you'd like the filter to be 50 percent, use 0.5.

General Query and Plan Info Section
The General Query and Plan Information section is in the center panel by default. It contains the Text

Data tab and the Plan XML tab.
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Common Operations

If you modify the query in the Command Text tab, the query text and XML synchronize when you

generate a new Estimated or Actual Plan from the toolbar.

The T-SQL statements synchronize with the Statements tree, meaning that if you select a row on the

Tree view it auto-selects the associated T-SQL statement and its execution plan, and vice versa.

Context Menu Options

Command Text Panel

Command Description

Undo Allows you the undo pasting the recent query. 

Cut Cuts the selected text to the clipboard.

Copy Copies the selected text to the clipboard.

Paste Pastes the selected text from the clipboard. 

Select All Selects the text in the active tab.
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Save SQL Saves the text data as a .sql file.

Word Wrap Wraps text to the current width of the panel.

Edit
Connection 

Allows you to edit the SQL Server connection.

Command Description

Text Data Panel

Command Description

Copy Copies the selected text to the clipboard.

Select All Selects the text in the active tab.

Copy to Command Text
Copies the selected information to the Command Text tab,
overwriting any text currently in the tab.

Save SQL Saves the text data as a .sql file. 

Word Wrap Wraps text to the current width of the panel. 

Open Allows you to open a new Plan Explorer session.

Plan XML Panel
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Command Description

Copy Copies the selected text to the clipboard.

Paste Plan XML Allows you to paste a new plan.

Select All Selects the text in the active tab.

Save Execution Plan Saves the current execution plan.

Word Wrap Wraps text to the current width of the panel.

Plan Details
Plan Explorer offers several options and styles that can be applied to the Plan Diagram. When a plan is

saved, these visual plan properties are maintained as part of the Plan Explorer session. Create a very specific

view of the Plan Diagram for sharing and troubleshooting purposes. For a complete rundown of this feature,

see the Plan Explorer PRO 2.5: Query plans your way  blog post.

Plan Diagram Toolbar

Option Description

Zoom
Scales the Plan Diagram between six percent and 400 percent of its original size. Use
CTRL + Mouse Wheel to perform this operation.

Filter Filter nodes from the Plan Diagram based on cost.

Stretch Stretches the links between Plan Diagram nodes.

Flatten Flattens the space between node levels in the Plan Diagram.

Mode There are several modes available that change the layout of the entire  Plan Diagram.

Link Style The Link Style used between nodes in the Plan Diagram.

Rotation Rotates the entire Plan Diagram 90 degrees.

Auto-Fit Automatically fits the plan in the Plan Diagram tab. 

Defaults All Plan Diagram options are reset.

Plan Diagram Context Menu
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Command Description

Actual Costs Shows metrics captured during Actual Plan retrieval.

Estimated Costs Shows metrics associated with the Estimated Plan.

Show Per Node Costs
The default view, costs are per node, representing each individual nodes
contribution to the total cost.

Show Cumulative Costs
Costs are cumulative, representing each individual nodes contribution plus
the contribution of any of its children.

Costs By
I/O—Show costs by I/O
CPU—Show costs by CPU
CPU + I/O—Show costs by CPU +I/O

Line Widths By
Rows
Data Size (MB)

Show Color Scale
Node costs are highlighted with an appropriate color scale, ranging from a
light yellow to red.

Show Nested
Procedures

Shows nested procedures.

Show Full Object
Names

Objects are represented with full object names.

Expand Expressions Expands all expressions. 

Copy Output List Copies the output list to the clipboard. 

Missing Index Details Displays the index details.

Expand All Subnodes Expands all the subnodes.
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Show Plan Layout
Control

Shows the layout controls. 

Zoom
Various options for zooming in and out. Alternatively, use CTRL + Mouse
Wheel.

Command Description

Plan Tree

The Plan Tree tab contains a tree representation of the plan's operations and associated metrics. Use the

arrows to expand and collapse sections of the Plan Tree. Right-click any column header, and use the Column

Chooser command to access additional plan metrics. Any significant differences between estimates and

actuals are highlighted, as are possible problematic operations like scans and bookmark lookups.

Context Menu Options

Option Description

Copy > Cell Copies the selected cell.

Copy > Row Copies the selected row.

Copy > All Copies all column data. 

Top Operations
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The Top Operations tab contains a sortable list view of all plan operations. The  List view is sorted by total

cost descending by default so you can immediately see which operations are the highest cost.

Context Menu Options

Option Description

Copy > Cell Copies the selected cell.

Copy > Row Copies the selected row.

Copy > All Copies all column data. 

Query Columns

The Query Columns tab shows exactly how data is accessed for each column used by the query, including the

associated operation and estimated rows. This view helps you identify bookmark lookups or index scans

occurring due to non-covering indexes. Columns for related operations are grouped together (indicated by a

thick separator bar), with the indexes used and bookmark (key / rid) lookup columns highlighted in orange.

This helps you see how indexes can be modified to eliminate lookups.

Join Diagram
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If there are joins present in the query, the  Join Diagram tab is present, showing a visual representation of the

joins involved. This is like the database diagram or Query Designer features within the Management Studio,

but it only shows the columns that actively participate in joins. Plan Explorer looks past any views and shows

the base tables and base columns, making it quicker to analyze queries that involve, for example, nested

views.

Parameters

The Parameters tab shows compiled and runtime parameters referenced in the plan, if any exist (otherwise

the tab isn't visible). An Estimated Plan only shows the compiled parameter value. An Actual Plan compares

compiled values with runtime that can in turn help point out potential parameter sniffing issues.

Expressions
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If there are any expressions in the plan the Expressions tab is present. You can see the operator type, the

shorthand expression name, and the expanded version of the expression, as well as any other expressions

that reference it or are referenced by it, allowing you to quickly see if you're performing the same operations

repeatedly.

Context Menu Options

Option Description

Copy > Cell Copies the selected cell.

Copy > Row Copies the selected row.

Copy > All Copies all column data. 

Table I/O

The Table I/O tab is present for Actual Plans. This tab breaks down all the reads from a query by object,

making it easy to see where most of your I/O is coming from.

Plan Diagram Icons
The following is a list of the icons, and what they signify in Plan Explorer :

A

Icon Description
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Adaptive join

Aggregate

Arithmetic Expression

Assert

Assign

Icon Description

B

Icon Description

Build Batch Hatch table

Bitmap
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Bookmark Lookup

Icon Description

C

Icon Description

Clustered index delete

Clustered index insert

Clustered index merge

Clustered index scan

Clustered index seek

Clustered index update
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Collapse

Column Store index delete

Column Store index insert

Column Store index merge

Column Store index scan

Column Store index update

Compute Scalar

Concatenation

Icon Description
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Condition

Constant Scan

Convert

Cursor

Icon Description

D

Icon Description

Declare

Delete

Deleted Scan
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Distribute Stream

Dynamic

Icon Description

F

Icon Description

Fast Forward

Fetch Query

Filter

Foreign key reference

H

Icon Description
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Hash Match / Hash Match Aggregation / Hash Match Union

Hash Match Root

Hash Match Team

Icon Description

I

Icon Description

Index Delete

Index Insert

Index Scan

Index Seek
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Index Spool

Index Update

Insert

Inserted Scan

Intrinsic

Iterator / Iterator Catch All

Icon Description

K

Icon Description

Key Lookup
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Key Set

Icon Description

L

Icon Description

Locate

Logical Op Distribute Streams

Logical Op Reparation Streams

Log Row Scan

M

Icon Description

Merge
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Merge Interval

Merge Join

Icon Description

N -O

Icon Description

Nested Loops

Overlay Batch Mode

Overlay Batch Mode Parallel

Overlay Error

Overlay Information
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Overlay Parallel

Overlay Warning

Icon Description

P

Icon Description

Parallelism

Parameter Table Scan

Population Query

Print

Put
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R

Icon Description

Rank

Refresh Query

Remote Delete

Remote Index Scan

Remote Index Seek

Remote insert

Remote Query
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Remote Scan

Remote Update

Repartition Stream

Result

RID Lookup

Row Count Spool

Icon Description

S

Icon Description

Segment
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Select

Select Into

Sequence

Sequence Project

Set Function

Snapshot

Sort

Icon Description
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Split

Spool

Stream Aggregate

Switch

Icon Description

T

Icon Description

Table Delete

Table Insert
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Table Merge

Table Scan

Table Spool

Table Update

Table Value Function

Top

TSQL

Icon Description

U-W

Icon Description
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UDX

Unknown

Update

Window Aggregate

Window Spool

Icon Description
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Plan Explorer Index Analysis
Last Modified on 15 July 2021

Introduction
The Plan Explorer  Index Analysis tab provides a sandbox environment for planning indexing strategy relative

to a specific operation in a query.

For Index Analysis to populate, the query must execute from within the  Plan Explorer session, using the Get

Actual Plan menu option.

Additional Information: See the SQL Sentry Index Analysis blog post for more details and examples.

The Statement Tree and Plan Diagram

For more information, see the Integrated Plan Explorer topic. 

The Text Data Area

For more information, see the Integrated Plan Explorer topic. 

The Indexes Data Grid

Overall view of the Index Analysis tab in a Plan Explorer session

https://www.sentryone.com/blog/aaronbertrand/sql-sentry-v10-index-analysis
http://app.knowledgeowl.com/help/integrated-plan-explorer-overview
http://app.knowledgeowl.com/help/integrated-plan-explorer-overview
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The top row is the index Total Score that's based on several factors including covering, value density, sorting

effectiveness, and seek-ability. 100 percent is the best possible score; however, there are some situations

that prevent the possibility of a 100 percent score. One known cause is when columns are missing statistics. 

Column statistics are provided for each table column used by the query, with table columns used by the

selected operation displayed in bold.

Data Grid Columns:

Name Description

Table Column Name of the column in the relevant database table.

Last Statistics Update The date the column statistics were last updated.

Update Statistics Automatically updates the existing statistics. 

Avg. Length Average length of data values.

Estimated Size (MB) The estimated size of the column values (in MB).

Output Checked if the column is an output for the selected operation.

Sort Type Sort order (ASC, DESC).

Sort Order Ordinal position of the column in the sort.

Predicate
The search or join predicate(s) applied to the table column by the
operation.

Columns in the grid to the right of the Predicate column all represent indexes. These include both special

case indexes, as well as the indexes defined on the table.

Indexes can be modified, as well as scripted for create, drop, or drop and create. Manually update statistics

using the button at the bottom of the index column.

Index Coloring:

Shades of green indicate that the ordinal position of the column is such that a favorable operation may

occur, such as a seek over a scan. Darker shades of green indicate that the column is filtered.
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Yellow indicates that the column is used in the query, and covered, but isn't part of the left subset of the

index key. Included columns are also listed in yellow.

Red indicates that the column involved isn't covered by the index.

The Parameters Data Grid
The parameters grid lists parameters used by the query. This differs from the Plan Explorer Parameters  tab

in that it uses tipping point logic to help determine the type of operation (Seek or Scan) that the optimizer

might choose for that parameter value. This isn't an exact science, and should be used as a rough guideline.

The parameters grid provides a Test Value column that allows you to enter a new parameter value and asks

for a new Estimated Plan. This allows you to test different parameter values against the plan to see if the

plan shape changes given that parameter value.

The small arrows to the right of the parameter values allow you to quickly place the value of that parameter

into the Test Values column.

Options for Parameters Data Grid

Option Description

Tipping Point Range

Select this box to display  the tipping point range on the histogram chart.

Additional Information: Blog posts from Kimberly Tripp on the tipping
point.

Est/Actual Rows Select this box to show estimated and actual rows on the histogram chart.

Range Rows

Toggle this switch to Range Rows to display the total range rows on the
histogram chart.

Note:  Total range rows can be helpful for visualizing range predicates.

https://www.sqlskills.com/blogs/kimberly/category/the-tipping-point/
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Avg Range Rows

Toggle this switch to Avg Range Rows  to display the average range rows on
the histogram chart.

Note:  Average range rows can be helpful for when working with equality
predicates.

Option Description

The Statistics Histogram Chart
The Histogram chart displays the histogram steps for the index statistics visually. This allows you to quickly

spot potential parameter sniffing issues.

This chart also works in conjunction with the parameters grid, and selected parameters that are present in the

histogram have their histogram buckets highlighted on the chart. This also works for parameter ranges.

Note:  Hover over the histogram chart to view more details.

Histogram chart details
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Note:  For more information about Index Analysis, see the Sentry v10 : Index Analysis blog post.

Update Statistics

Update the statistics for a selected index on the Index Analysis tab by selecting the Update Statistics button

 . On the Update Statistics window, select  the sample mode, select a sample percentage, and

then select Update to refresh the index statistics.

Note:  The Sample percentage for an index is set to 20 percent by default. 

Update Statistics Window

Option Description

Statistic The selected index statistic that you want to update.

Statistic
mode

SAMPLE
Scans a sample of the selected index based on the desired
sample percentage.

FULLSCAN Scans the entire selected index.

RESAMPLE Resamples the selected index.

https://www.sentryone.com/blog/aaronbertrand/sql-sentry-v10-index-analysis
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Sample
Percentage

This option is only available if you select the SAMPLE scan mode option. Scans the
entered percentage of the index.

Update Updates the statistics based off of your selections.

Cancel Closes the Update Statistics window.

Option Description

Script Index

View the associated script for a selected index by selecting the Script Index button . 

Script Index Window

Option Description

Script Editor
View and make edits to the script for the selected index in the script editor
view. 

Drop checkbox
Displays the Drop index statement when selected. Removes the Drop index
statement when deselected.

Create checkbox
Displays the Create index statement when selected. Removes the Create
index statement when deselected.

Copy to Clipboard Copies the entire index script to the clipboard.

Execute Executes the index script.

Close Close the Script Index window.
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Option Description
Script Index Window Context Menu

Context menu option Description

Copy Copies the selected text from the Script editor.

Select All Highlights all of the text in the Script editor.

Save SQL Saves the script as a .sql file.

Word Wrap Displays the script using word wrap to minimize horizontal scrolling.
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Plan Explorer Live Query Profile
Last Modified on 29 November 2021

Live Query Profiling allows for the capture and replay of live query execution data. To enable the collection

of live query data, select the arrow next to Get Actual Plan , and then select With Live Query Profile . When

this setting is enabled, live query execution data is captured along with the actual plan. Plan Explorer adds

the benefit of being able to replay a live query. This replay data saves as part of the Plan Explorer session file.

Related Settings

Setting Description

Default Actual Plan Collection Mode
Allows you to choose between getting only an
actual plan or getting the actual plan and live
profile by default.

Live Profile Data Collection Interval
Determines how often live query data is
collected. The minimum value is 100 ms.

For more information about this feature, see the Plan Explorer Update Just in "Time" for the New Year  blog

post. 

Note:  A minimum of SQL Server 2014 SP1 is required to collect live query profile data.

https://blogs.sentryone.com/jasonhall/plan-explorer-update/


77

Plan Explorer Deadlock Files
Last Modified on 28 June 2021

Plan Explorer allows you to open deadlock files. Deadlock (.xdl) files can be captured or collected from

several places, including the following:

SQL Sentry Performance Analysis—Captures deadlocks happening in your monitored environment.

These .xdl files can be exported and then shared.

SQL Server Profiler—Allows you to create a trace that captures deadlock events. 

Additional Information: For more information about SQL Server Profiler, see the Save Deadlock

Graphs MSDN article.

Opening a Deadlock File

After you've captured a deadlock file (.xdl), open it with Plan Explorer just as you would a plan file. A

deadlock displays in two main sections:

The top section contains a Deadlock Grid view that breaks down the deadlock by SPID and lock

resource. 

The bottom section contains the Deadlock Graph with representations for each process and resource

involved in the deadlock.

https://www.sentryone.com/sql-server/sql-tuning
http://msdn.microsoft.com/en-us/library/ms190465.aspx
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Deadlock Grid View

In the Deadlock Grid view each record is expandable to view the details regarding the processes that were

involved in the deadlock. For more information about the metrics displayed, see the Deadlock Metrics

section, following.

The deadlock victim is highlighted with a red background.

Deadlock Graph

The Deadlock Graph is formed according to the deadlock XML. Process and Resource nodes are

independently represented, along with any relationships that exist between them.

The deadlock victim is highlighted with a red background.

The numbers (one) and associated arrows, between each node, indicate the actual sequence of events

that took place leading to the deadlock.

The letters indicate the requested Lock mode.

Selecting object nodes in the graphical representation sets focus to that object in the Grid view.

Zoom in and out on the Deadlock Graph using Ctrl + mouse wheel, or through the right-click context

menu.

Drag and rearrange nodes as desired.

Deadlock Metrics

Deadlock Overview

Name Description

Victim SPID
The session process ID of the victim involved in
the deadlock.

Victim Host The workstation belonging to the victim thread.

Victim Application
The application name belonging to the victim
thread.

Victim Database
The name of the database on which the process
took place.

Victim Text Data The associated text data of the victim.

Deadlock XML The actual captured Deadlock XML.

Lock Details
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The Lock Details area breaks down the deadlock by specific lock types, including the owners and waiters

involved in each lock.

Name Description

SPID [ecid]
The session process ID of the associated
owner/waiter.

Host The workstation name.

Application The associated application.

Database The associated database.

Log Used The amount of log space used by the process.

Deadlock Priority

Specifies the deadlock priority. Zero (0) or
Normal is the default priority. In cases where
each session has the same deadlock priority, SQL
Server chooses the victim based on the least
expensive session to roll back.

Additional Information: For more
information, see the SET DEADLOCK_PRIORITY
MSDN article. 

Wait Time
Time in (ms) milliseconds spent waiting on the
resource.

Transaction Start Time Time that the transaction began.

Last Batch Start Time
The last time a client process started batch
execution.

Last Batch Completion Time
The last time a client process completed batch
execution.

Mode/Type

The mode/type designates the resource lock
mode.

Additional Information: For more information
about lock mode, see the SQL Server Transaction
Locking and Row Versioning Guide MSDN
article. 

Status State of the task.

Isolation Level

The current transaction isolation level.

Additional Information: For more information
on isolation levels, see the SQL Documentation
MSDN article. 

https://docs.microsoft.com/en-us/sql/t-sql/statements/set-deadlock-priority-transact-sql?view=sql-server-2017
https://docs.microsoft.com/en-us/sql/relational-databases/sql-server-transaction-locking-and-row-versioning-guide
https://docs.microsoft.com/en-us/sql/?view=sql-server-2017
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Login Name The Login Name associated with the session.

Lock Partition The table partition(s) involved in the deadlock. 

Request Type
The type of request, including wait, lock, or
convert. 

Name Description

Owner/Waiter Details

Name Description

Object Indicates the associated object name.

Line Number
The line number that was being executed when
the lock occurred.

Text Data The associated text data.
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