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Enhancements/Features 

IPReceiver/DC-09 Compatibility with TCP/IP Protocol 

The previous version of the IPReceiver and DC-09 driver was released in patch 45, but it would only 

communicate via UPD protocol. We changed this to support TCP/IP protocol and added a section to the 

appsetting.json file to include additional port information for the TCP/IP connection. Updated 

documentation is in the IPReceiver and DC-09 Receiver guide. 

 

Resolution Code Signal Billing Overage 

We added the ability to calculate alarm and signal overages for billing based on Resolution Codes. This 

change includes if billing is done with Monitoring Services or with Class Codes. 

https://manitou-knowledge-base.knowledgeowl.com/help/ipreceiver-and-dc-09-receiver
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We added a new checkbox for resolution codes in the Supervisor Workstation under Maintenance > 

Resolution Codes. 

 

Any resolution code under any group can be marked as Billable. Having the False Alarm selected or 

cleared will not change the Billable functionality. 

We added a new checkbox called Billable Resolution Codes Only to Dealer and Monitoring Company 

Billing Charges > Signal Overages. This is available in both the Operator Workstation and the Manitou Web 

Client. 
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When this checkbox is selected, Signal Overages will ONLY be calculated on alarms (dispatched) or signals 

that are closed with a resolution code that has been marked as being Billable. Any alarm or signal that is 

closed without a resolution or with a non-billable resolution code will not count against the set allowable 

limit. If there are multiple groups of resolution codes, marking one of any of the groups will mark the 

alarm or signal as being billable. 

Changing a resolution code in a customer’s activity and re-running the Customer Signal Count Generator 

> Dealer Excess Billing reports will reflect accordingly for billable and non-billable resolution codes. 

Application Corrections 

Manitou Web Client: Headers for maintenance issues has USER ID twice - on the main top 

level maintenance issues [00118715] 

Issue: There should be only one column for User ID on the Maintenance Issues headers. 

Solution: We removed the second instance of the User ID column.  

Manitou Web Client: Customer details contact info out of order when adding new 

[00139878] 

Issue: When adding a new phone number or email to the existing contacts card on the customer details 

page, it placed the information at the bottom, rather than group it with the phone number or email. 

Solution: We fixed an issue in the Web Client where the Contact Points of an entity (Customer, Dealer, 

Company, Authority, Agency, Branch or Global Keyholder) were displayed in the order they were entered 

and not grouped by category of Phone, Email, and Website. 

Contacts will now be grouped in order by Phone Number, Email, and Web Address. 

Manitou Web Client: Adding a device when creating a new customer, the TX number isn’t 

sticking after being chosen, shows as “None” 

Issue: When creating a new customer, adding a device, choosing a Tx No. from the provided dropdown, 

and clicking done, it did not save. It showed the TX as None. 

Solution: We fixed the issue where the transmitter number was not saving correctly and was always 

showing as “None” when adding a device in the wizard and after the customer was saved. We also 

improved the transmitter display format to show “ID – Description” for better clarity and consistency with 

the dropdown. 
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Manitou Web Client: Unable to click & drag to highlight text from the activity log (to copy 

things to clipboard) [00137232, 00138260] 

Issue: Before patch 45 a user could highlight and copy from Customer Activity and copy from Customer 

Contacts, with the Contact Points. After upgrading this option was no longer available.  

Solution: We re-instituted previous behavior. A user can again copy and paste from the Customer Activity 

Logs as well as the contacts on the Contact List. 

Manitou Web Client: TempClose TX Programming command is present in the Operator 

Workstation but not present in Web Client [00140010] 

Issue: The TempClose programming command showed as available in the Operator Workstation but not 

as an option in the Manitou Web Client. 

Solution: We added the TempClose programming command to programming commands in the Manitou 

Web Client. 

Manitou Web Client: Editing an action pattern from call list to contact customer does not 

update properly [00139358] 

Issue: In the Manitou Web Client when updating the customer call list and changing to a customer contact 

step, it appeared that the action pattern retained the name of the call list in the customer contact step. 

For example: 

 

Solution: We fixed this issue and now editing and changing a Contact Customer Action Pattern line by 

replacing the call list to a single contact saves correctly. 

Manitou Web Client/BoldNet: The Recurring and Permanent On-Test options don’t always 

show [00124722] 

Issue: The Recurring and Permanent On-Test Options were inconsistently missing depending on when the 

On-Test Form was last used, which password was validated, and whether the user had logged out and 

back in. The workaround was to re-size the browser window. 
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Solution: We made changes to ensure stability of the On-Test form to maintain all on-test options 

including Recurring and Permanent On-Test. 

Media Gateway writes to MG_OPERATIONS table but never deletes creating memory 

problems [00139358] 

Issue: Media Gateway had memory issues at various sites. 

Solution: We fixed a bug where the reverse command records in the MG_OPERATIONS table were not 

deleted when they should be. This eventually caused Media Gateway to run out of memory when running 

and when starting; it would fail to start.  

We fixed a bug where we were sending the pending reverse commands from the Media Gateway service to 

the console as fast as possible until the pending reverse command count hit 0. We now only send updates 

when the collection changes. 

We fixed a bug where the Outbound Calls count and view in the Media Gateway user interface would 

never reach 0 after at least one outbound call had been made when running Media Gateway as a service. 

We made a change to not write to the error log when reaching the end of a list sent from the Media 

Gateway service to the Media Gateway console. 

We fixed a bug where if an autotext line driver errored (typically sending to the SMS provider), then 

subsequent autotext reverse commands were not being processed. 

We changed Media Gateway so that it clears the reverse command records out of the MG_OPERATIONS 

table on startup. 

We fixed how we track reverse command attempts so that the records reflecting them in the 

MG_OPERATIONS table do not get orphaned. 

We fixed the user interface so that the Outbound Calls count does not oscillate between the real count 

and 0 every second. 

Operator Workstation: Having the PSAP lookup tool open prevents Auto-Get alarm from 

coming to an operator screen [00131281] 

Issue: If the PSAP Lookup Tool window was actively open, the Auto-Get function did not distribute alarms 

to the operators who were in Auto-Get mode. 
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Solution: We corrected the behavior and having the PSAP Lookup Tool open will no longer prevent 

operators in Auto-Get mode from receiving alarms. In addition, for the PSAP Lookup Tool, we corrected 

the same behavior with these dialogs: 

▪ File > Print 

▪ File > Properties 

▪ File > Change Password 

▪ View > Event Maps 

▪ Tools > Verify Password 

▪ Help > About Operator Workstation 

If dialogs are open and Auto-Get is activated, alarms will open for the user. Users will still need to close 

out of the dialogs to process the alarm. 

This does NOT apply to these dialogs: 

▪ File > Logoff 

▪ Tools > Change CustomerID 

Media Gateway is not releasing memory for large signals [00139358] 

Issue: Memory usage for the Media Gateway continued to climb after processing large signals. This led to 

overall slowness and sometimes crashing of the UI.  

Solution: We made multiple changes to correct memory usage issues:  

▪ Cleared out previous signal’s memory usage in FTP and FILE connectors. 

▪ Cleared out previous signal’s memory usage for all Universal Connector drivers. 

▪ Media Gateway now garbage collects memory every 10 seconds to reflect actual memory usage in 

the operating system. 

▪ Log lines in the Media Gateway Console or Standalone truncate after 1024 characters to save 

memory and put (truncated) at the end. See log files for more signal data. 

▪ Removed logging of XML Signal and XML Packet lines because they caused out of memory 

exceptions. 

Manitou Web Client: Global keyholder cross street and subdivision not saving [00002186] 

Issue: Adding an address to Global Keyholder had a place for subdivision/cross street, but it did not 

appear after saving it, and when users attempted to edit again, it was blank. 

Solution: Address information for Persons or Contacts does not contain fields for Subdivision and Cross 

street. These fields are only valid for an entity addresses. We updated the Global Keyholder address to be 
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consistent and removed the fields from the Global Keyholder address entry. The fields did not exist for 

Global Keyholder address in the Operator Workstation. 

Manitou Web Client: UserIDs not sorting the same way they do in the Operator Workstation 

[00126034] 

Issue: The user view in the web client was not in numeric order. There was no way to put them in numeric 

order and the functionality should match the order in the OWS. 

Solution: There was an issue with the User Id listing in the Manitou Web Client where the web client 

should have been sorting like the OWS. We changed this to support sorting like the OWS. 

Manitou Web Client: Not allowing to specify AR Number on create/push to Sedona 

[00145620] 

Issue: The MWC does not behave the same way the OWS does in allowing a user to specify an AR Account 

Number when using the CREATE button to push an account to SedonaOffice. 

Solution: We updated the MWC so that it behaves in the same manner as the OWS when pushing a 

customer into SedonaOffice and specifying the Account Number during the CREATE. 

Manitou Web Client: Report settings not working for maintenance issues [00127014] 

Issue: Users were unable to run the Maintenance Issues report in MWC with the Resolved resolution 

selected. 

Solution: When running the Maintenance report from a customer, it should display prompts for Log Date, 

Last Action Date, Resolved Date, and Appointment Date. Selecting one of these dates is required when 

running a report for Resolved issues. These date prompts were not displaying on the MWC. This has been 

fixed. 

Maintenance Issues report template options not showing as expected when running the 

template in the Manitou Web Client [00109412] 

Issue: When setting up a templated version of the Maintenance Issue report, selected components did not 

show accurately when running the templated report from the MWC. 

Solution: One reason the options were not showing is that the MWC was missing the date to/from fields 

for Log Date, Last Action Date, Resolved Date and Appointment Date. This was resolved. We made 

additional changes to ensure that all options chosen on the template are what is shown when running the 

report from the MWC. 
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Suspend until action in an action pattern not showing correctly [00002184] 

Issue: Customer Maintenance > Action Pattern > Suspend Until: When adding a suspend until command it 

displayed oddly. It added class=’var’> to the schedule name after it was applied. 

Solution: We fixed an issue with displaying the "SUSPEND Until" Action Pattern type. This is for both 

action pattern data entry and when the action pattern displays in the alarm. It now displays correctly: 

SUSPEND UNTIL TIME IS IN SCHEDULE AP. 

Customer activity log display mode setting is not correctly retained during alarm handling 

[00136168] 

Issue: When switching between alarms, the alarm activity format showed that it had been changed to 

something other than standard, but the activity displayed still showed as standard.  

Solution: The MWC had an issue when processing an alarm and the user changed the activity log format 

from standard to something else, like report. When closing the alarm, the next alarm should still display 

the activity log in report format. Instead, the headings were report headings but the data was back to 

standard. 

This has been fixed. Changing the activity log format will now display the data appropriately for the next 

alarm until the format is changed. 

We also changed the Reset button to keep the display format as set, only clearing filter options. This 

resembles OWS when doing a clear on the filter; the format display does not change. We also fixed what 

triggered the Restore button to indicate that there is a filter in effect. It was triggered even when there 

were no filters in effect. 

Custom dashboards not allowing for customization other than alarm counts [00002184] 

Issue: When setting up new Custom Dashboards with custom cards, regardless of the options selected, 

the details only show options for Alarm Counts.  

Solution: We corrected the behaviors and the custom cards now show the selectable details based on the 

initial options that are chosen. 

PBXServer not transferring call after getting a transferred event 

Issue: PBXServer was not always transferring a call if it got a transferred call event.  

Solution: The system assumed the call was gone and removed the call ID but the call was being 

transferred from the extension to the same extension and the call ID should not have been removed. We 

corrected this. 
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Media Gateway: Getting 365Oauth connector errors [00142600] 

Issue: Users got errors when processing multiple emails at a time using the 365Oauth connector.  

Solution: We updated the process to fetch/delete/process emails one at a time. 

Manitou Web Client/BoldNet: Logging in under a user that has less than Administrator 

permission is not showing Customer Activity 

Issue: When logging into the Manitou Web Client or Bold Net as a user that has less than administrator 

permission profile, the Customer Activity no longer displayed. 

Solution: The bug was introduced with changes in this corrected issue Customer activity log display mode 

setting is not correctly retained during alarm handling [00136168] in patch 47. We corrected the behavior 

and any permission profile that has access to the Customer Activity will now see the activity as expected. 

Database Changes 

FAANL table: added column BILLABLE — this shows if a resolution code has been marked as billable. 

INSTCHG table: added column BILLRESONLY — this shows if a dealer has billing rates set up for Signal 

Overage, this will be marked if they only want to bill for resolution codes that have been marked as 

billable 

REPORTLIST_D table: We updated the parameter list for the Maintenance Issues Report to include Log 

Date, Last Action Date, Resolution Date, and Appointment Date 

System Requirements 

Minimum System Requirements 

▪ Windows Server 2016 

▪ 8 GB Memory 

▪ Dual Core Processor 

▪ Microsoft® SQL Express 2016 / Microsoft SQL Server 2016 

▪ 50 GB of Free Space for Database 

▪ Windows 11 for Operator Workstations 

TLS 1.2 is now supported, and ALL servers should be configured to support this. The Nartac IIS Crypto tool 

is very useful for verifying this is supported. 
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.NET 4.8 is required for full compatibility with current updates of the PBX server and several other Manitou 

components. https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements  

If you are updating Media Gateway, PBX Server, or LocationServer please make sure that the latest 

Microsoft OLEDB drivers are installed. This should just be done on ALL servers. 

https://docs.microsoft.com/en-us/sql/connect/oledb/download-oledb-driver-for-sql-server?view=sql-

server-ver15.  

.Net 4.8 is needed for VCC on workstations that use ONVIF or Avigilon 7 drivers. 

Manitou Web Clients and BoldNet requires the use of a certificate issued by a valid certificate authority. 

We do not support the use of invalid self-signed certificates in a production environment. 

End-of-Support 

Microsoft periodically ends support for some products. Due to this we can no longer support the 

following: 

▪ Windows Server 2012 R2 and older 

▪ Microsoft® SQL Express 2012 / Microsoft SQL Server 2012 and older 

▪ Windows 10 Home and Pro and older 

https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements
https://docs.microsoft.com/en-us/sql/connect/oledb/download-oledb-driver-for-sql-server?view=sql-server-ver15
https://docs.microsoft.com/en-us/sql/connect/oledb/download-oledb-driver-for-sql-server?view=sql-server-ver15
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